METODES NUMERICS Practica 1
QT - Curs 2011-12

Un problema tipic en enginyeria és dissenyar un pont. Considereu el segiient model format

per barres d’acer que tenen un modul de Young de F = 200GPa (GigaPascals) i un area de

seccié A = 3250mm?.

280kN, 10k 80k 360kN
600 600 600 600 600 600

El simbol a la cantonada esquerra significa que 'estructura esta fixada per aquest canté i

el stmbol a la dreta, significa que l'estructura té restringit el moviment vertical. Les fletxes

indiquen les carregues del pont. Sén forces puntuals de 280, 210, 280 i 360 kN (kiloNewtons).
L’objectiu és I'estudi de les deformacions, les forces de reaccio i les tensions axials.



METODES NUMERICS Practica 1 (Resolucié)
QT - Curs 2011-12

Preprocés

1. Crear els Keypoints
Els Keypoints son els extrems de cada viga.

e Definim 7 Keypoints tal i com mostra la taula seglient:

. Coordenades

Keypoints < y

1 0 0

2 3600 0

3 7200 0

4 10800 0

5 1800 3118

6 5400 3118

7 9000 3118

e A “ANSYS Main Menu” seleccionem:
Preprocessor > Modeling > Create > Keypoints > In Active CS

ANSYS Main Menu ®|

Preferences
Bl Preprocessor
Element Type
Real Constants
Material Props
Sections
Modeling
Bl Create
B Keypoints
#1 On Working Plane
In Active CS
#1 On Line
&1 On Line w/Ratio
&1 On Node
&1 KP between KPs
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I apareix la segiient finestra:

A Create Keypoints in Active Coordinate 5 I-A_J
[K] Create Keypoints in Active Coordinate Systemn
MPT  Keypoint number

Y. Z Location in active C5

OK

Apply

Per a definir el primer Keypoint (x = 01y = 0), posem un 1 a Keypoint number,
introduim les coordenades z i ¥, i cliquem a Apply.

e Fem el mateix per la resta de punts. Quan introduim I'iltim punt cliquem a OK
enlloc de Apply.

1]
POINIS

TYPE NUM




2. Crear les linies

e En el menu principal seleccionem:
Preprocessor > Modeling > Create > Lines > Lines > In Active Coord

I apareix la segiient finestra:

* pick i Unpick

v Bingle {" Eox

" Polygon ¢ cirele
[ Loop

Count
Maximam
Minimam

FEeyPF Ho.

* List of Items

{ Min, Max, Inc

OFE

Reset

Pick A11

e Utilitzem el ratoli per clicar sobre el punt 1 i seguidament al 2, i apareix una linia.

e Repetim el mateix per a crear la resta de linies. Ens ha de quedar com mostra la
segient imatge:
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3. Definir el tipus d’element

e En el menu principal seleccionem:
Preprocessor > Element > Add/FEdit/Delete

A cerer o N ==

Defined Element Types:




e Cliquem a Add i seleccionem I'element que mostra la imatge.

Library of Element Types Structural Mass

3D finit stn 180
Beam spar 8
Pipe bilinear 10
Solid actuator 11
Shell

Solid-Shell |zn spar 1

Element type reference number
0K | Cancel | Help |

4. Definir propietats geometriques

e En el menu principal seleccionem:
Preprocessor > Real Constants > Add/Edit/Delete

Defined Real Constant Sets

MOME DEFIMED

Add... | Edit... | Delete |

Close | Help |




e Cliquem a Add i seleccionem Type 1 LINKI (de fet, és I'inic element que hem
definit). Cliquem a OK i apareix:

Element Type Reference No. 1

Real Constant Set No.

Cross-sectional area AREA

Initial strain ISTRM

Cancel |

e Introduim larea (3250mm?) a Cross-sectional area, cliquem a OK i tanquem la
finestra de Real Constants (fixem-nos que apareix Set 1).

5. Definir propietats del material

e En el menu principal seleccionem:
Preprocessor > Material Props > Material Models

e Doble clic a:
Structural > Linear > FElastic > Isotropic

Material Edit Favorite Help

— Material Models Defined — Material Models Available

@ Structural
@ Linear
& Elastic

o TR
€ Orthotropic
@ Anisotropic

MNenlinear

£ Density

Thermal Expansion

Damping

@ Erictinn Casffiriant

kil




e Introduim el modul de Young (200G Pa) al camp EX.

Linear Isotropic Material Properties for Material Mumber 1

T

Temperatures

EX 200000}

PRXY

Add Temperature | Delete Temperature |

| Cancel |

6. Definir el mallat
Primer cal definir el nombre de divisions de cada element:

e En el menu principal seleccionem:
Preprocessor > Meshing > Size Cntrls > ManualSize > Lines > All Lines

[LESIZE] Element sizes on all selected lines
SIZE  Element edge length

MOV Mo, of element divisions

(NDIV is used only if SIZE is blank or zero)
KYMNDIV SIZE,NDIV can be changed

SPACE Spacing ratio

Show more options

OK | Cancel | Help |

e En el camp NDIV introduim el nombre de divisions que volguem, en aquest cas 1.
Posem 1 i cliquem a OK.



Ara cal mallar:

e En el menu principal seleccionem:
Preprocessor > Meshing > Mesh > Lines
I cliquem a Pick All a la finestra Mesh Lines.

Ha de quedar com mostra la segiient imatge:
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Solucio

Un cop definit el model és moment d’aplicar les restriccions i les carregues.

1. Definir el tipus d’analisi
S’ha de dir a ANSYS com volem que resolgui el problema.

e Seleccionem:
Solution > Analysis Type > New Analysis

e Seleccionem un analisi Static i cliquem a OK.

[ANTYPE] Type of analysis

" Modal

~ Harmonic

" Transient

" Spectrum

™ Eigen Buckling

" Substructuring/CMS

Help I

2. Aplicar restriccions

e Seleccionem:
Solution > Define Loads > Apply > Structural > Displacement > On Keypoints

# pick (" Unpick

Iy Single " Box

€ Polygen (" circle
(i Loop

Count
Mai mim
Minimm

KeyP Ho.

(¢ List of Items

@ Min, Max, Inc

OF I npplyl

Reset | Cancel |

Bick R11 | Help |

e Seleccionem el punt 1 i cliquem a OK a la finestra Apply U,ROOT on KPs.
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e El punt 1 esta fix, aixi doncs, seleccionem All DOF i escribim un 0 a VALUE.

|/\ Apply UROT an KPs

[DK] Apply Displacements (U,ROT) on Keypoints
Lab2 DOFsto be constrained

Apply as j
If Constant value then:

VALUE Displacement value

KEXPMND Expand disp to nodes?

oK ‘ Apply | Cancel | Help ‘

e Fem el mateix per a l'altre extrem (punt 4), pero restringint només 1’eix vertical
(seleccionem UY enlloc de All DOF). Ens ha de quedar:

i
ELEMENTS
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3. Aplicar les carregues
Hi ha quatre carregues verticals cap abaix: 280kN, 210kN, 280kN i 360kN, situades en

el punt 1, 2, 3 i 4 respectivament.
e Seleccionem:
Solution > Define Loads > Apply > Structural > Force/Moment > On Keypoints
e Seleccionem el punt 1 i cliquem a OK a la finestra Apply F/M on KPs.

e A Direction of force/mom seleccionem FY i a VALUE introduim —280000 (segons
les unitats introduides i per tal de ser coherents hem de posar les carregues en N).

T, ——
.ﬂ. Apply F/M on KPs L )

[FK] Apply Force/Moment on Keypoints

Lab  Direction of force/mom FY -

Apply as |C0nstantva|ue j

If Constant value then:

WVALUE Force/moment value - 280000

Cancel | Help ‘

e Fem el mateix per a les altres carregues i ens quedara com mostra la imatge:

il
ELEMENTS
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4. Resolem el sistema

e Seleccionem:
Solution > Solve > Current LS

SOLUTION OPTIOHS

PROBLEH DIHEMSIOMALITY. . . . .. ... .. ..
DEGREES OF FREEDOR. . . . . .
AHALYSIS TVPE . . o0 v v i i i i e

LOAD STEP HUMBER. . . . . . . e ———
TR AT M0 ETHE. LORD STEP. 4l [SOLVE] Begin Solution of Current Load Step
STEP CHAHGE BOUNDARY CONDITION
PRINT OUTPUT CONTROLS . . . .
DATRBASE OUTPUT CONTROLS. © |

Review the summary information in the lister window (entitled "/STATUS
Command"), then press OK to start the solution.

Cancel

e Cliquem a OK.

e Un cop solucionat el sistema apareix la segiient finestra, la qual tancarem ( Close) si
tot és correcte.

@ Selution is done!
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Postprocés

1. Forces de reacci6

e Seleccionem en el mentu principal:
General Postproc > List Results > Reaction Solu

[PRRSOL] List Reaction Solution

Lab Ttemn to be listed All itemns
Struct force FX
F\ff
FZ
Struct moment MX
MY
MZ
All struc mome M

‘ All struc forc F

Cancel | Help I

|
PRINT F REACTION S0LUTIONS PER WODE
sewkck POIT] TOTAL REACTION SOLUTION LISTING deeckek

LOAD STEP= 1 SUBSTEP= 1
TIHE= 1.0000 LOAD CRSE= O

THE FOLLOHING ¥,%,2 SOLUTIONS ARE IH THE GLOBAL COORDIMATE SYSTEH

HOOE F¥ Y
1 0.58208E-10 0.51333EH15
q 0.61667E+06

TOTAL YALLES
YALUE  0.52208E-10 0.11300E+07
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2. Deformacio

e Seleccionem:
General Postproc > Plot Results > Deformed Shape

'\ Plot Deformed Shape. =
| L=
[PLDISP] Plot Deformed Shape

KUMND Items to be plotted
(" Def shape only

(" Def + undeformed

oK ‘ Apply ‘ Cancel ‘ Help

e Seleccionem Def + undef edge i cliquem a OK.

DISPLACEMENT
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3. Desviacié Per a una visié més detallada de la desviacié podem fer:

e Seleccionem:
General Postproc > Plot results > Contour Plot > Nodal Solution

J\ Contour Nodal Solution ]
-

Item to be contoured |
88 Favorites - I
@ Medal Solution
g DOF Selution
@ X-Compenent of displacement
@@ ¥-Compenent of displacement
| WDisplacement vector sum
(B8 Stress
Total Strain
|53 Elastic Strain
Plastic 5train
(58 Creep Strain T
Thermal Strain
[58 Total Mechanical and Thermal Strain

¥ Swelling strain j
Undisplaced shape key
Undisplaced shape key | Deformed shape only j
Scale Factor Auto Calculated
Additional Options @]
ak | Apply | Cancel | Help |

e A DOF solution seleccionem Displacement vector sum i cliquem a OK.

NODAL SOLUTION
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e També ho podem obtenir en format llista:
General Postproc > List Results > Nodal Solution

p- ———

File

FRINT U MODAL SOLUTION PER MODE
stk POST] NODAL DEGREE OF FREEDOH LISTING seetokr

LOAD STEP= 1 SUBSTEP= 1
TIHE=  1.0000 LOAD CASE= O

THE FOLLOHIMG DEGREE OF FREEOOH RESULTS ARE IM THE GLOBAL COORDINATE SYSTEH
HODE 1H] ¥ Iz L5UH

d.0000 0.0000 0.0000 0.0000
0. 604 -6.5750 0.0000 fi. 6181
2.1 -6.9923 0.0000 1.3643
3.1334 0.0000 0.0000 3.13H
3.0836 -3.5033 0.0000 4.6671
1.5816 -1.2363 0.0000 7.4093
7 -0.49736E-01 -3.7330 0.0000 3.7333

HAXIHUR ABSOLUTE MALUES
HOOE 9 f 0 fi
YALUE  3.1334 -7.2363 0.0000 7.4093

4. Tensions axials
Per obtenir les tensions axials cal usar una taula d’elements (Element Table). La taula
d’elements és diferent per a cada element, per tant, cal anar a ’ajuda i mirar quines
opciones cal ficar per obtenir el que volem. En aquest cas, I’element és del tipus LINK1.
Si mirem 'arxiu d’ajuda veurem que es pot trobar les tensions axials (SAXL) a partir de
una ETABLE (Element Table) utilitzant LS, 1.

e Seleccionem:
General Postproc > Element Table > Define Table
I cliquem a Add.

[AVPRIM] Eff MU for EQV strain |:|

[ETABLE] Define Additional Element Table fems

Lab User label for item

Item,Comp Results data item Strain-thermal - | |SMISC, -
Strain-plastic NMISC, i_E_I
Strain-creep i
Strain-other | |LEPEL,
Contact ‘E| LEPTH, =

Optimization

By sequence num

(For "By sequence num", enter sequence
no. in Selection box. See Table 403

in Elements Manual for seq. numbers.)

oK Apply Cancel Help

e Tal i com mostra la imatge posem SAXL al camp LAB, a Item,Comp seleccionem
By sequence number i LS, i afegim un 1 després de LS al requadre de sota.

e Cliquem a OK i tanquem la finestra Element Table.
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e Podem veure el grafic anant a: General Postproc > FElement Table > Plot Elem
Table

'\ Contour Plot of Element Table Da L l—”’_]
i i

[PLETAE] Contour Element Table Data

Itlab Item to be plotted m =
Avglab Average at common nodes? |Nc - do not avg j
oK | Apply | Cancel ‘ Help |

e Comprovem que esta seleccionat SAXL i cliquem OK.

ELEMENT SOLUTION

[(HOAVE)
=7.409
91.189
SMX =91.1&9

e També podem obtenir els resultats en format llista anant a: General Postproc >
Element Table > List Elem Table

e A la finestra List Element Table Data’ seleccionem SAXL i cliquem OK.
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PRINT ELEHENT TRELE ITEHS PER ELEHENT
ertotet: POST] ELEHENT TRELE LISTING Aetctetet

STAT  CURRENT
ELEH  SAEL

1 41447
2 a%0Ea
34551
4 82,900
5 82900
f
?
]

-5.2000
4.2900
91,129

9 -91,189
i -E2.aad
11 -91.183

HINIAUH MALUES
ELEA a
YALUE  -91.139

HAX IHUH MALUES
ELEA g
YALUE  91.139
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